Clio Manage EU Performance Degradation
Incident Report for Clio (EU)
Resolved
This incident has been resolved. Clio Manage should be fully operational. We are continuing to monitor to mitigate any performance issues.
Posted Jan 08, 2022 - 14:01 PST
Investigating
We are currently investigating an issue which may impact Clio Manage performance and accessibility on the EU server. We will update when more information is available.
Posted Jan 08, 2022 - 13:06 PST
This incident affected: Clio (EU).