Clio Degraded Performance

Incident Report for Clio (EU)

Resolved

Reported performance issues and errors logging into Clio products have been resolved.
Posted May 28, 2025 - 18:18 IST

Investigating

We are currently investigating reports of issues logging into Clio Apps and intermittent application errors.
Posted May 28, 2025 - 18:02 IST
This incident affected: Clio (EU).