Clio is Inaccessible

Incident Report for Clio (EU)

Resolved

This incident has been resolved.
Posted Sep 17, 2019 - 13:35 IST

Update

We have identified the issue and are working to resolve it.
Posted Sep 17, 2019 - 13:34 IST

Investigating

We have identified the issue and are working to resolve it.
Posted Sep 17, 2019 - 13:34 IST
This incident affected: Clio (EU).