Clio EU is inaccessible
Incident Report for Clio (EU)
Resolved
This incident has been resolved.
Posted Jun 16, 2020 - 21:04 IST
Monitoring
Clio is now fully accessible and the issue has been resolved.
Posted Jun 16, 2020 - 21:01 IST
Investigating
We are currently investigating an issue affecting the ability to access Clio.
Posted Jun 16, 2020 - 20:47 IST
This incident affected: Clio (EU).