Clio is Inaccessible

Incident Report for Clio (EU)

Resolved

This incident has been resolved.
Posted Jan 08, 2022 - 20:30 GMT

Update

We have identified the issue and are working to resolve it.
Posted Jan 08, 2022 - 20:28 GMT

Investigating

We have identified the issue and are working to resolve it.
Posted Jan 08, 2022 - 20:28 GMT
This incident affected: Clio (EU).