Clio is Inaccessible

Incident Report for Clio (EU)

Resolved

This incident has been resolved.
Posted Feb 19, 2021 - 16:44 GMT

Update

We have identified the issue and are working to resolve it.
Posted Feb 19, 2021 - 16:20 GMT

Investigating

We have identified the issue and are working to resolve it.
Posted Feb 19, 2021 - 16:19 GMT
This incident affected: Clio (EU).